Curve3dGetParameterAtLength Method
|
Retrieves the parameter value of the point
whose arc length distance is the input length.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public double GetParameterAtLength(
double datumParameter,
double length,
bool direction,
double tolerance
)
Public Function GetParameterAtLength (
datumParameter As Double,
length As Double,
direction As Boolean,
tolerance As Double
) As Double
public:
double GetParameterAtLength(
double datumParameter,
double length,
bool direction,
double tolerance
)
member GetParameterAtLength :
datumParameter : float *
length : float *
direction : bool *
tolerance : float -> float
Parameters
- datumParameter
- Type: SystemDouble
[in] Parameter value.
- length
- Type: SystemDouble
[in] Sub-interval of the curve.
- direction
- Type: SystemBoolean
[in] Parameter direction.
- tolerance
- Type: SystemDouble
[in] Geometric tolerance.
Return Value
Type:
Double
Parameter value as the
double type.
See Also