Curve2dGetClosestPointTo Method (Curve2d, Tolerance)
|
Retrieves the closest points between this
curve and the passed curve within a specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve2d[] GetClosestPointTo(
Curve2d curve,
Tolerance tolerance
)
Public Function GetClosestPointTo (
curve As Curve2d,
tolerance As Tolerance
) As PointOnCurve2d()
public:
array<PointOnCurve2d^>^ GetClosestPointTo(
Curve2d^ curve,
Tolerance tolerance
)
member GetClosestPointTo :
curve : Curve2d *
tolerance : Tolerance -> PointOnCurve2d[]
Parameters
- curve
- Type: Teigha.GeometryCurve2d
[in] Curve to which closest points are calculated.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
PointOnCurve2d
Array of closest points. The point with index 0 is the closest
point on this curve; the point with index 1 is the closest point on
the other curve.
See Also