EllipticalArc2dSet Method (Point2d, Vector2d, Vector2d, Double, Double,
Double, Double)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
Point2d center,
Vector2d majorAxis,
Vector2d minorAxis,
double majorRadius,
double minorRadius,
double startAngle,
double endAngle
)
Public Sub Set (
center As Point2d,
majorAxis As Vector2d,
minorAxis As Vector2d,
majorRadius As Double,
minorRadius As Double,
startAngle As Double,
endAngle As Double
)
public:
void Set(
Point2d center,
Vector2d majorAxis,
Vector2d minorAxis,
double majorRadius,
double minorRadius,
double startAngle,
double endAngle
)
member Set :
center : Point2d *
majorAxis : Vector2d *
minorAxis : Vector2d *
majorRadius : float *
minorRadius : float *
startAngle : float *
endAngle : float -> unit
Parameters
- center
- Type: Teigha.GeometryPoint2d
- majorAxis
- Type: Teigha.GeometryVector2d
- minorAxis
- Type: Teigha.GeometryVector2d
- majorRadius
- Type: SystemDouble
- minorRadius
- Type: SystemDouble
- startAngle
- Type: SystemDouble
- endAngle
- Type: SystemDouble
See Also