EllipticalArc2d Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class EllipticalArc2d : Curve2d

The EllipticalArc2d type exposes the following members.

Constructors
  Name Description
Public method EllipticalArc2d
Initializes a new instance of the EllipticalArc2d class
Public method EllipticalArc2d(CircularArc2d)
Initializes a new instance of the EllipticalArc2d class
Public method EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double)
Initializes a new instance of the EllipticalArc2d class
Public method EllipticalArc2d(Point2d, Vector2d, Vector2d, Double, Double, Double, Double)
Initializes a new instance of the EllipticalArc2d class
Top
Properties
Methods
  Name Description
Public methodStatic member Create
Public method IntersectWith(LinearEntity2d)
Public method IntersectWith(LinearEntity2d, Tolerance)
Public method IsCircular
Public method IsCircular(Tolerance)
Public method IsInside(Point2d)
Public method IsInside(Point2d, Tolerance)
Public method Set(CircularArc2d)
Public method Set(Point2d, Vector2d, Vector2d, Double, Double)
Public method Set(Point2d, Vector2d, Vector2d, Double, Double, Double, Double)
Public method SetAngles
Public method SetAxes
Top
See Also

©  Bricsys NV. All rights reserved.