CoordinateSystem2dEquals Method

Checks objects for equality.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public override sealed bool Equals(
        Object obj
)

Parameters

obj
Type: SystemObject
[in] Object to be checked for equality.

Return Value

Type: Boolean
true if the object is not null and: 1. Clipped vertices are equal; 2. Clipped segment source labels are equal; 3. Clip conditions are equal.
Remarks
For Equals and GetHashCode methods, an override should be completed together to match logic; if Equals returns true, hashcodes should be the same; the same hashcodes do not always mean that the objects are the same because of collisions; hashcodes should be formed on fields on which equality is based; sometimes the Equals method is taken from a ++ object, but since pointers are compared, you still can use GetHashCode from here, while Equals can be overridden in a derived class.
See Also

©  Bricsys NV. All rights reserved.