AugmentedPolylineCurve3d Constructor (Curve3d, Double, Double,
Double)
|
Constructor for the AugmentedPolylineCurve3d
class. Constructs a polyline that approximates the passed curve of
the specified parametric range with the specified precision.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public AugmentedPolylineCurve3d(
Curve3d curve,
double fromParameter,
double toParameter,
double eps
)
Public Sub New (
curve As Curve3d,
fromParameter As Double,
toParameter As Double,
eps As Double
)
public:
AugmentedPolylineCurve3d(
Curve3d^ curve,
double fromParameter,
double toParameter,
double eps
)
new :
curve : Curve3d *
fromParameter : float *
toParameter : float *
eps : float -> AugmentedPolylineCurve3d
Parameters
- curve
- Type: Teigha.GeometryCurve3d
[in] 3D curve to be approximated.
- fromParameter
- Type: SystemDouble
[in] Start of the parameter range of the curve.
- toParameter
- Type: SystemDouble
[in] End of the parameter range of the curve.
- eps
- Type: SystemDouble
[in] Approximation distance (step) value.
See Also