CircularArc3d Constructor (Point3d, Vector3d, Vector3d, Double,
Double, Double)
|
Constructor for the CircularArc3d class.
Creates a circle with the specified center, normal and
radius.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CircularArc3d(
Point3d center,
Vector3d normal,
Vector3d referenceVector,
double radius,
double startAngle,
double endAngle
)
Public Sub New (
center As Point3d,
normal As Vector3d,
referenceVector As Vector3d,
radius As Double,
startAngle As Double,
endAngle As Double
)
public:
CircularArc3d(
Point3d center,
Vector3d normal,
Vector3d referenceVector,
double radius,
double startAngle,
double endAngle
)
new :
center : Point3d *
normal : Vector3d *
referenceVector : Vector3d *
radius : float *
startAngle : float *
endAngle : float -> CircularArc3d
Parameters
- center
- Type: Teigha.GeometryPoint3d
[in] Center of a circular arc.
- normal
- Type: Teigha.GeometryVector3d
[in] Normal vector of a 3D circular arc.
- referenceVector
- Type: Teigha.GeometryVector3d
[in] Vector that indicates the direction of the zero rotation angle
of this circular arc.
- radius
- Type: SystemDouble
[in] Radius of this circular arc.
- startAngle
- Type: SystemDouble
[in] Start angle of a circular arc.
- endAngle
- Type: SystemDouble
[in] End angle of a circular arc (must be greater than
startAngle).
See Also