NurbCurve2dSetFitData Method (KnotCollection, Point2dCollection,
Vector2d, Vector2d, Tolerance, Boolean)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void SetFitData(
KnotCollection fitKnots,
Point2dCollection fitPoints,
Vector2d startTangent,
Vector2d endTangent,
Tolerance fitTolerance,
bool periodic
)
Public Sub SetFitData (
fitKnots As KnotCollection,
fitPoints As Point2dCollection,
startTangent As Vector2d,
endTangent As Vector2d,
fitTolerance As Tolerance,
periodic As Boolean
)
public:
void SetFitData(
KnotCollection^ fitKnots,
Point2dCollection^ fitPoints,
Vector2d startTangent,
Vector2d endTangent,
Tolerance fitTolerance,
bool periodic
)
member SetFitData :
fitKnots : KnotCollection *
fitPoints : Point2dCollection *
startTangent : Vector2d *
endTangent : Vector2d *
fitTolerance : Tolerance *
periodic : bool -> unit
Parameters
- fitKnots
- Type: Teigha.GeometryKnotCollection
- fitPoints
- Type: Teigha.GeometryPoint2dCollection
- startTangent
- Type: Teigha.GeometryVector2d
- endTangent
- Type: Teigha.GeometryVector2d
- fitTolerance
- Type: Teigha.GeometryTolerance
- periodic
- Type: SystemBoolean
See Also