NurbCurve2d Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class NurbCurve2d : SplineEntity2d

The NurbCurve2d type exposes the following members.

Constructors
  Name Description
Public method NurbCurve2d
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(EllipticalArc2d)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(LineSegment2d)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Point2dCollection)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Point2dCollection, Tolerance)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Int32, PolylineCurve2d, Boolean)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Point2dCollection, Vector2dCollection, Boolean)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Int32, KnotCollection, Point2dCollection, Boolean)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Point2dCollection, Vector2dCollection, Tolerance, Boolean)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Int32, KnotCollection, Point2dCollection, DoubleCollection, Boolean)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, Tolerance)
Initializes a new instance of the NurbCurve2d class
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum, Tolerance)
Initializes a new instance of the NurbCurve2d class
Top
Properties
  Name Description
Public property DefinitionData
Public property EvalMode
Public property FitData
Public property FitKnotParameterization
Public property FitTolerance
Public property NumFitPoints
Public property NumWeights
Top
Methods
  Name Description
Public method AddControlPointAt
Public method AddFitPointAt
Public method AddKnot
Public methodStatic member Create
Public method DeleteControlPointAt
Public method DeleteFitPointAt
Public method ElevateDegree
Public method GetFitPointAt
Public method GetFitTangents
Public method GetParametersOfC1Discontinuity
Public method GetParametersOfC1Discontinuity(Tolerance)
Public method GetParametersOfG1Discontinuity
Public method GetParametersOfG1Discontinuity(Tolerance)
Public method GetWeightAt
Public method HardTrimByParams
Public method InsertKnot
Public method JoinWith
Public method MakeClosed
Public method MakeNonPeriodic
Public method MakeOpen
Public method MakePeriodic
Public method MakeRational
Public method PurgeFitData
Public method SetEvaluateMode
Public method SetFitData(Int32, Point2dCollection)
Public method SetFitData(Int32, Point2dCollection, Tolerance)
Public method SetFitData(Point2dCollection, Vector2d, Vector2d)
Public method SetFitData(Point2dCollection, Vector2d, Vector2d, Tolerance)
Public method SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Boolean)
Public method SetFitData(Point2dCollection, Vector2d, Vector2d, KnotParameterizationEnum, Tolerance)
Public method SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Tolerance, Boolean)
Public method SetFitPointAt
Public method SetFitTangents
Public method SetWeightAt
Top
See Also

©  Bricsys NV. All rights reserved.