CircularArc3dIntersectWith Method (PlanarEntity, Tolerance)
|
Retrieves intersection points between this
circular arc and the passed plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Point3d[] IntersectWith(
PlanarEntity plane,
Tolerance tolerance
)
Public Function IntersectWith (
plane As PlanarEntity,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ IntersectWith(
PlanarEntity^ plane,
Tolerance tolerance
)
member IntersectWith :
plane : PlanarEntity *
tolerance : Tolerance -> Point3d[]
Parameters
- plane
- Type: Teigha.GeometryPlanarEntity
[in] A 3D plane to intersect with.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Point3d
Array of intersection points.
See Also