PlanarEntity Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public abstract class PlanarEntity : Surface

The PlanarEntity type exposes the following members.

Properties
  Name Description
Public property Coefficients
Public property Normal
Public property PointOnPlane
Top
Methods
  Name Description
Public method ClosestPointToLinearEntity(LinearEntity3d)
Public method ClosestPointToLinearEntity(LinearEntity3d, Tolerance)
Public method ClosestPointToPlanarEntity(PlanarEntity)
Public method ClosestPointToPlanarEntity(PlanarEntity, Tolerance)
Public methodStatic member Create
Public method GetCoordinateSystem
Public method IntersectWith(LinearEntity3d)
Public method IntersectWith(LinearEntity3d, Tolerance)
Public method IsCoplanarTo(PlanarEntity)
Public method IsCoplanarTo(PlanarEntity, Tolerance)
Public method IsParallelTo(LinearEntity3d)
Public method IsParallelTo(PlanarEntity)
Public method IsParallelTo(LinearEntity3d, Tolerance)
Public method IsParallelTo(PlanarEntity, Tolerance)
Public method IsPerpendicularTo(LinearEntity3d)
Public method IsPerpendicularTo(PlanarEntity)
Public method IsPerpendicularTo(LinearEntity3d, Tolerance)
Public method IsPerpendicularTo(PlanarEntity, Tolerance)
Top
See Also

©  Bricsys NV. All rights reserved.