NurbSurface Constructor (Int32, Int32, Int32, Int32, Int32,
Int32, Point3dCollection, DoubleCollection, KnotCollection,
KnotCollection)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public NurbSurface(
int degreeU,
int degreeV,
int propsInU,
int propertiesInV,
int numberControlPointsInU,
int numberControlPointsInV,
Point3dCollection controlPoints,
DoubleCollection weights,
KnotCollection knotsInU,
KnotCollection knotsInV
)
Public Sub New (
degreeU As Integer,
degreeV As Integer,
propsInU As Integer,
propertiesInV As Integer,
numberControlPointsInU As Integer,
numberControlPointsInV As Integer,
controlPoints As Point3dCollection,
weights As DoubleCollection,
knotsInU As KnotCollection,
knotsInV As KnotCollection
)
public:
NurbSurface(
int degreeU,
int degreeV,
int propsInU,
int propertiesInV,
int numberControlPointsInU,
int numberControlPointsInV,
Point3dCollection^ controlPoints,
DoubleCollection^ weights,
KnotCollection^ knotsInU,
KnotCollection^ knotsInV
)
new :
degreeU : int *
degreeV : int *
propsInU : int *
propertiesInV : int *
numberControlPointsInU : int *
numberControlPointsInV : int *
controlPoints : Point3dCollection *
weights : DoubleCollection *
knotsInU : KnotCollection *
knotsInV : KnotCollection -> NurbSurface
Parameters
- degreeU
- Type: SystemInt32
- degreeV
- Type: SystemInt32
- propsInU
- Type: SystemInt32
- propertiesInV
- Type: SystemInt32
- numberControlPointsInU
- Type: SystemInt32
- numberControlPointsInV
- Type: SystemInt32
- controlPoints
- Type: Teigha.GeometryPoint3dCollection
- weights
- Type: Teigha.GeometryDoubleCollection
- knotsInU
- Type: Teigha.GeometryKnotCollection
- knotsInV
- Type: Teigha.GeometryKnotCollection
See Also