Spline Constructor (Point3d, Vector3d, Vector3d, Double,
Double, Double)
|
Initializes a new instance of the
Spline class
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Spline(
Point3d center,
Vector3d unitNormal,
Vector3d majorAxis,
double radiusRatio,
double startAngle,
double endAngle
)
Public Sub New (
center As Point3d,
unitNormal As Vector3d,
majorAxis As Vector3d,
radiusRatio As Double,
startAngle As Double,
endAngle As Double
)
public:
Spline(
Point3d center,
Vector3d unitNormal,
Vector3d majorAxis,
double radiusRatio,
double startAngle,
double endAngle
)
new :
center : Point3d *
unitNormal : Vector3d *
majorAxis : Vector3d *
radiusRatio : float *
startAngle : float *
endAngle : float -> Spline
Parameters
- center
- Type: Teigha.GeometryPoint3d
- unitNormal
- Type: Teigha.GeometryVector3d
- majorAxis
- Type: Teigha.GeometryVector3d
- radiusRatio
- Type: SystemDouble
- startAngle
- Type: SystemDouble
- endAngle
- Type: SystemDouble
See Also