Curve3dIsDegenerate Method (Entity3d, Tolerance)

Checks whether this curve is degenerate and returns the type of entity that the curve degenerates to (if degenerate).
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public bool IsDegenerate(
        out Entity3d result,
        Tolerance tolerance
)

Parameters

result
Type: Teigha.GeometryEntity3d
[out] Retrieves the type of degenerate entity.
tolerance
Type: Teigha.GeometryTolerance
[in] Geometric tolerance.

Return Value

Type: Boolean
true if this curve is degenerate, false otherwise.
See Also

©  Bricsys NV. All rights reserved.