TextStyle Constructor (String, String, Double, Double, Double,
Double, Boolean, Boolean, Boolean, Boolean, Boolean, String)
|
Initializes a new instance of the
TextStyle
class
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public TextStyle(
string fontName,
string bigFontName,
double textSize,
double x,
double obliqueAngle,
double trackingPercent,
bool isBackward,
bool isUpsideDown,
bool isVertical,
bool isOverLined,
bool isUnderlined,
string styleName
)
Public Sub New (
fontName As String,
bigFontName As String,
textSize As Double,
x As Double,
obliqueAngle As Double,
trackingPercent As Double,
isBackward As Boolean,
isUpsideDown As Boolean,
isVertical As Boolean,
isOverLined As Boolean,
isUnderlined As Boolean,
styleName As String
)
public:
TextStyle(
String^ fontName,
String^ bigFontName,
double textSize,
double x,
double obliqueAngle,
double trackingPercent,
bool isBackward,
bool isUpsideDown,
bool isVertical,
bool isOverLined,
bool isUnderlined,
String^ styleName
)
new :
fontName : string *
bigFontName : string *
textSize : float *
x : float *
obliqueAngle : float *
trackingPercent : float *
isBackward : bool *
isUpsideDown : bool *
isVertical : bool *
isOverLined : bool *
isUnderlined : bool *
styleName : string -> TextStyle
Parameters
- fontName
- Type: SystemString
- bigFontName
- Type: SystemString
- textSize
- Type: SystemDouble
- x
- Type: SystemDouble
- obliqueAngle
- Type: SystemDouble
- trackingPercent
- Type: SystemDouble
- isBackward
- Type: SystemBoolean
- isUpsideDown
- Type: SystemBoolean
- isVertical
- Type: SystemBoolean
- isOverLined
- Type: SystemBoolean
- isUnderlined
- Type: SystemBoolean
- styleName
- Type: SystemString
See Also