MlineGetClosestPointTo Method (Point3d, Vector3d, Boolean,
Boolean)
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Point3d GetClosestPointTo(
Point3d givenPoint,
Vector3d normal,
bool extend,
bool excludeCaps
)
Public Function GetClosestPointTo (
givenPoint As Point3d,
normal As Vector3d,
extend As Boolean,
excludeCaps As Boolean
) As Point3d
public:
Point3d GetClosestPointTo(
Point3d givenPoint,
Vector3d normal,
bool extend,
bool excludeCaps
)
member GetClosestPointTo :
givenPoint : Point3d *
normal : Vector3d *
extend : bool *
excludeCaps : bool -> Point3d
Parameters
- givenPoint
- Type: Teigha.GeometryPoint3d
- normal
- Type: Teigha.GeometryVector3d
- extend
- Type: SystemBoolean
- excludeCaps
- Type: SystemBoolean
Return Value
Type:
Point3d
See Also