Curve2dGetNormalPoint Method (Point2d, Tolerance)
|
Retrieves the point on this curve where normal
extends through the passed point within the specified
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve2d GetNormalPoint(
Point2d point,
Tolerance tolerance
)
Public Function GetNormalPoint (
point As Point2d,
tolerance As Tolerance
) As PointOnCurve2d
public:
PointOnCurve2d^ GetNormalPoint(
Point2d point,
Tolerance tolerance
)
member GetNormalPoint :
point : Point2d *
tolerance : Tolerance -> PointOnCurve2d
Parameters
- point
- Type: Teigha.GeometryPoint2d
[in] Point for which corresponding point on this curve is
retrieved.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
PointOnCurve2d
Point whose normal passes through the input point.
See Also