Point3d Constructor (PlanarEntity, Point2d)

Constructor for the Point3d class. Constructs a 3D point by the formula: p + uAxis * pnt2d.x + vAxis * pnt2d.y, where p, uAxis, and vAxis are returned by the function call plane.get (p, uAxis, vAxis);.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Point3d(
        PlanarEntity plane,
        Point2d point
)

Parameters

plane
Type: Teigha.GeometryPlanarEntity
[in] A planar entity.
point
Type: Teigha.GeometryPoint2d
[in] 2D parameter in a plane's coordinates.
See Also

©  Bricsys NV. All rights reserved.