Rotates this point about the specified vector
by the specified angle.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Point3d RotateBy(
double angle,
Vector3d vector,
Point3d centerPoint
)
Public Function RotateBy (
angle As Double,
vector As Vector3d,
centerPoint As Point3d
) As Point3d
public:
Point3d RotateBy(
double angle,
Vector3d vector,
Point3d centerPoint
)
member RotateBy :
angle : float *
vector : Vector3d *
centerPoint : Point3d -> Point3d
Parameters
- angle
- Type: SystemDouble
[in] Rotation angle in radians.
- vector
- Type: Teigha.GeometryVector3d
[in] Axis of rotation.
- centerPoint
- Type: Teigha.GeometryPoint3d
[in] Point relative to which rotation is computed.
Return Value
Type:
Point3d
Rotated 3D point.
See Also