CubicSplineCurve3d Constructor (KnotCollection,
Point3dCollection, Vector3dCollection, Boolean)
|
Constructor for the CubicSplineCurve3d class.
Creates a cubic spline curve according to the passed
parameters.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CubicSplineCurve3d(
KnotCollection knots,
Point3dCollection fitPoints,
Vector3dCollection firstDerivatives,
bool periodic
)
Public Sub New (
knots As KnotCollection,
fitPoints As Point3dCollection,
firstDerivatives As Vector3dCollection,
periodic As Boolean
)
public:
CubicSplineCurve3d(
KnotCollection^ knots,
Point3dCollection^ fitPoints,
Vector3dCollection^ firstDerivatives,
bool periodic
)
new :
knots : KnotCollection *
fitPoints : Point3dCollection *
firstDerivatives : Vector3dCollection *
periodic : bool -> CubicSplineCurve3d
Parameters
- knots
- Type: Teigha.GeometryKnotCollection
[in] Knot vector.
- fitPoints
- Type: Teigha.GeometryPoint3dCollection
[in] Array of fit points.
- firstDerivatives
- Type: Teigha.GeometryVector3dCollection
[in] Array of first derivatives at the fit points.
- periodic
- Type: SystemBoolean
[in] Flag that specifies whether a cubic spline curve should be
periodic (closed).
See Also