AugmentedPolylineCurve3d Constructor (KnotCollection, Point3dCollection, Vector3dCollection)

Constructor for the AugmentedPolylineCurve3d class. Constructs an object with knots, control points, and vectors.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public AugmentedPolylineCurve3d(
        KnotCollection knots,
        Point3dCollection controlPoints,
        Vector3dCollection vectorBundle
)

Parameters

knots
Type: Teigha.GeometryKnotCollection
[in] Array of knots.
controlPoints
Type: Teigha.GeometryPoint3dCollection
[in] Array of 3D control points.
vectorBundle
Type: Teigha.GeometryVector3dCollection
[in] Array of 3D vectors.
See Also

©  Bricsys NV. All rights reserved.