AcadDimArcLengthClass Class

Inheritance Hierarchy
SystemObject
  BricscadDbAcadDimArcLengthClass
Namespace:  BricscadDb
Assembly:  Interop.BricscadDb (in Interop.BricscadDb.dll) Version: 21.0.0.0
Syntax
public class AcadDimArcLengthClass : IAcadDimArcLength, 
        AcadDimArcLength, IAcadObjectEvents_Event

The AcadDimArcLengthClass type exposes the following members.

Constructors
  Name Description
Public method AcadDimArcLengthClass
Initializes a new instance of the AcadDimArcLengthClass class
Top
Properties
  Name Description
Public property AltRoundDistance
Public property AltSubUnitsFactor
Public property AltSubUnitsSuffix
Public property AltSuppressLeadingZeros
Public property AltSuppressTrailingZeros
Public property AltSuppressZeroFeet
Public property AltSuppressZeroInches
Public property AltTextPrefix
Public property AltTextSuffix
Public property AltTolerancePrecision
Public property AltToleranceSuppressLeadingZeros
Public property AltToleranceSuppressTrailingZeros
Public property AltToleranceSuppressZeroFeet
Public property AltToleranceSuppressZeroInches
Public property AltUnits
Public property AltUnitsFormat
Public property AltUnitsPrecision
Public property AltUnitsScale
Public property Application
Public property ArcEndParam
Public property ArcPoint
Public property ArcStartParam
Public property Arrowhead1Block
Public property Arrowhead1Type
Public property Arrowhead2Block
Public property Arrowhead2Type
Public property ArrowheadSize
Public property CenterPoint
Public property color
Public property Database
Public property DecimalSeparator
Public property DimensionLineColor
Public property DimensionLineExtend
Public property DimensionLinetype
Public property DimensionLineWeight
Public property DimLine1Suppress
Public property DimLine2Suppress
Public property DimLineInside
Public property Document
Public property EntityName
Public property EntityTransparency
Public property EntityType
Public property ExtensionLineColor
Public property ExtensionLineExtend
Public property ExtensionLineOffset
Public property ExtensionLineWeight
Public property ExtLine1Linetype
Public property ExtLine1Point
Public property ExtLine1Suppress
Public property ExtLine2Linetype
Public property ExtLine2Point
Public property ExtLine2Suppress
Public property ExtLineFixedLen
Public property ExtLineFixedLenSuppress
Public property Fit
Public property ForceLineInside
Public property FractionFormat
Public property Handle
Public property HasExtensionDictionary
Public property HasLeader
Public property HorizontalTextPosition
Public property Hyperlinks
Public property IsPartial
Public property Layer
Public property Leader1Point
Public property Leader2Point
Public property LinearScaleFactor
Public property Linetype
Public property LinetypeScale
Public property Lineweight
Public property Material
Public property Measurement
Public property Normal
Public property ObjectID
Public property ObjectID32
Public property ObjectName
Public property OwnerID
Public property OwnerID32
Public property PlotStyleName
Public property PrimaryUnitsPrecision
Public property Rotation
Public property RoundDistance
Public property ScaleFactor
Public property StyleName
Public property SubUnitsFactor
Public property SubUnitsSuffix
Public property SuppressLeadingZeros
Public property SuppressTrailingZeros
Public property SuppressZeroFeet
Public property SuppressZeroInches
Public property SymbolPosition
Public property TextColor
Public property TextFill
Public property TextFillColor
Public property TextGap
Public property TextHeight
Public property TextInside
Public property TextInsideAlign
Public property TextMovement
Public property TextOutsideAlign
Public property TextOverride
Public property TextPosition
Public property TextPrefix
Public property TextRotation
Public property TextStyle
Public property TextSuffix
Public property ToleranceDisplay
Public property ToleranceHeightScale
Public property ToleranceJustification
Public property ToleranceLowerLimit
Public property TolerancePrecision
Public property ToleranceSuppressLeadingZeros
Public property ToleranceSuppressTrailingZeros
Public property ToleranceSuppressZeroFeet
Public property ToleranceSuppressZeroInches
Public property ToleranceUpperLimit
Public property TrueColor
Public property UnitsFormat
Public property VerticalTextPosition
Public property Visible
Top
Methods
  Name Description
Public method add_Modified
Public method ArrayPolar
Public method ArrayRectangular
Public method Copy
Public method Delete
Public method Erase
Public method GetBoundingBox
Public method GetExtensionDictionary
Public method GetXData
Public method Highlight
Public method IntersectWith
Public method Mirror
Public method Mirror3D
Public method Move
Public method remove_Modified
Public method Rotate
Public method Rotate3D
Public method ScaleEntity
Public method SetXData
Public method TransformBy
Public method Update
Top
Events
  Name Description
Public event Modified
Top
See Also

©  Bricsys NV. All rights reserved.