Torus Constructor (Double, Double, Point3d, Vector3d, Vector3d,
Double, Double, Double, Double)
|
Initializes a new instance of the
Torus class
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Torus(
double majorRadius,
double minorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
double startAngleU,
double endAngleU,
double startAngleV,
double endAngleV
)
Public Sub New (
majorRadius As Double,
minorRadius As Double,
origin As Point3d,
axisOfSymmetry As Vector3d,
referenceAxis As Vector3d,
startAngleU As Double,
endAngleU As Double,
startAngleV As Double,
endAngleV As Double
)
public:
Torus(
double majorRadius,
double minorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
double startAngleU,
double endAngleU,
double startAngleV,
double endAngleV
)
new :
majorRadius : float *
minorRadius : float *
origin : Point3d *
axisOfSymmetry : Vector3d *
referenceAxis : Vector3d *
startAngleU : float *
endAngleU : float *
startAngleV : float *
endAngleV : float -> Torus
Parameters
- majorRadius
- Type: SystemDouble
- minorRadius
- Type: SystemDouble
- origin
- Type: Teigha.GeometryPoint3d
- axisOfSymmetry
- Type: Teigha.GeometryVector3d
- referenceAxis
- Type: Teigha.GeometryVector3d
- startAngleU
- Type: SystemDouble
- endAngleU
- Type: SystemDouble
- startAngleV
- Type: SystemDouble
- endAngleV
- Type: SystemDouble
See Also