CircularArc3d Constructor (Point3d, Vector3d, Double)
|
Constructor for the CircularArc3d class.
Creates a circle with the specified center, normal and
radius.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CircularArc3d(
Point3d center,
Vector3d normal,
double radius
)
Public Sub New (
center As Point3d,
normal As Vector3d,
radius As Double
)
public:
CircularArc3d(
Point3d center,
Vector3d normal,
double radius
)
new :
center : Point3d *
normal : Vector3d *
radius : float -> CircularArc3d
Parameters
- center
- Type: Teigha.GeometryPoint3d
[in] Center of a circle.
- normal
- Type: Teigha.GeometryVector3d
[in] Normal vector of a 3D circle.
- radius
- Type: SystemDouble
[in] Radius of a circle.
See Also