Curve3dGetParameterOf Method (Point3d, Tolerance)

Retrieves the parameter value of a point within a specified tolerance.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public double GetParameterOf(
        Point3d point,
        Tolerance tolerance
)

Parameters

point
Type: Teigha.GeometryPoint3d
[in] Point on the curve.
tolerance
Type: Teigha.GeometryTolerance
[in] Geometric tolerance.

Return Value

Type: Double
Parameter value as the double type.
Remarks
If the point is not on the curve, the results are unpredictable. If you are not sure the point is on the curve, use the isOn () method instead.
See Also

©  Bricsys NV. All rights reserved.