DatabaseSaveAs Method (StreamBuf, SaveType, DwgVersion, Boolean,
Int32)
|
Saves content of the currently active database
according to the passed arguments.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void SaveAs(
StreamBuf fileBuf,
SaveType st,
DwgVersion version,
bool saveThumbnailImage,
int dxfPrecision
)
Public Sub SaveAs (
fileBuf As StreamBuf,
st As SaveType,
version As DwgVersion,
saveThumbnailImage As Boolean,
dxfPrecision As Integer
)
public:
void SaveAs(
StreamBuf^ fileBuf,
SaveType st,
DwgVersion version,
bool saveThumbnailImage,
int dxfPrecision
)
member SaveAs :
fileBuf : StreamBuf *
st : SaveType *
version : DwgVersion *
saveThumbnailImage : bool *
dxfPrecision : int -> unit
Parameters
- fileBuf
- Type: Teigha.RuntimeStreamBuf
[in] Stream buffer to which to write the database.
- st
- Type: Teigha.DatabaseServicesSaveType
[in] Save type represented by the SaveType enumeration.
- version
- Type: Teigha.DatabaseServicesDwgVersion
[in] A file version to which to save the file.
- saveThumbnailImage
- Type: SystemBoolean
[in] Flag that indicates whether to save a thumbnail image.
- dxfPrecision
- Type: SystemInt32
[in] .dxf file decimal digits precision. Currently ignored; a value
of 16 is used.
See Also