AugmentedPolylineCurve3d Constructor (Point3dCollection,
Vector3dCollection)
|
Constructor for the AugmentedPolylineCurve3d
class. Constructs a 3D polyline with vectors corresponding to each
control point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public AugmentedPolylineCurve3d(
Point3dCollection controlPoints,
Vector3dCollection vectorBundle
)
Public Sub New (
controlPoints As Point3dCollection,
vectorBundle As Vector3dCollection
)
public:
AugmentedPolylineCurve3d(
Point3dCollection^ controlPoints,
Vector3dCollection^ vectorBundle
)
new :
controlPoints : Point3dCollection *
vectorBundle : Vector3dCollection -> AugmentedPolylineCurve3d
Parameters
- controlPoints
- Type: Teigha.GeometryPoint3dCollection
[in] Array of 3D control points.
- vectorBundle
- Type: Teigha.GeometryVector3dCollection
[in] Array of 3D vectors.
See Also