Curve2dGetNormalPoint Method (Point2d)
|
Retrieves the point on this curve where normal
extends through the passed point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve2d GetNormalPoint(
Point2d point
)
Public Function GetNormalPoint (
point As Point2d
) As PointOnCurve2d
public:
PointOnCurve2d^ GetNormalPoint(
Point2d point
)
member GetNormalPoint :
point : Point2d -> PointOnCurve2d
Parameters
- point
- Type: Teigha.GeometryPoint2d
[in] Point for which corresponding point on this curve is
retrieved.
Return Value
Type:
PointOnCurve2d
Point whose normal passes through the input point.
See Also