Curve2dGetClosestPointTo Method (Point2d, Tolerance)
|
Retrieves the closest point on this curve to
the specified point within the specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve2d GetClosestPointTo(
Point2d point,
Tolerance tolerance
)
Public Function GetClosestPointTo (
point As Point2d,
tolerance As Tolerance
) As PointOnCurve2d
public:
PointOnCurve2d^ GetClosestPointTo(
Point2d point,
Tolerance tolerance
)
member GetClosestPointTo :
point : Point2d *
tolerance : Tolerance -> PointOnCurve2d
Parameters
- point
- Type: Teigha.GeometryPoint2d
[in] Point to which the closest point is calculated.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
PointOnCurve2d
The closest point on this curve.
See Also