Curve2dGetClosestPointTo Method (Point2d)
|
Retrieves the closest point on this curve to
the specified point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve2d GetClosestPointTo(
Point2d point
)
Public Function GetClosestPointTo (
point As Point2d
) As PointOnCurve2d
public:
PointOnCurve2d^ GetClosestPointTo(
Point2d point
)
member GetClosestPointTo :
point : Point2d -> PointOnCurve2d
Parameters
- point
- Type: Teigha.GeometryPoint2d
[in] Point to which the closest point is calculated.
Return Value
Type:
PointOnCurve2d
The closest point on this curve.
See Also