RadialDimension Constructor (Point3d, Point3d, Double, String,
ObjectId)
|
Constructor. Creates a RadialDimension object
with specified parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public RadialDimension(
Point3d center,
Point3d chordPoint,
double leaderLength,
string dimensionText,
ObjectId dimensionStyle
)
Public Sub New (
center As Point3d,
chordPoint As Point3d,
leaderLength As Double,
dimensionText As String,
dimensionStyle As ObjectId
)
public:
RadialDimension(
Point3d center,
Point3d chordPoint,
double leaderLength,
String^ dimensionText,
ObjectId dimensionStyle
)
new :
center : Point3d *
chordPoint : Point3d *
leaderLength : float *
dimensionText : string *
dimensionStyle : ObjectId -> RadialDimension
Parameters
- center
- Type: Teigha.GeometryPoint3d
Center point of the circle or arc to be measured.
- chordPoint
- Type: Teigha.GeometryPoint3d
Chord point on the circle or arc to be measured, and to which the
dimension line is drawn.
- leaderLength
- Type: SystemDouble
The distance from the chord point to the dogleg of the
dimension.
- dimensionText
- Type: SystemString
Dimension text to replace the measured value text.
- dimensionStyle
- Type: Teigha.DatabaseServicesObjectId
ObjectId of dimension style that is used to draw the dimension
entity.
See Also