RadialDimension Class |
The RadialDimension type exposes the following members.
Name | Description | |
---|---|---|
![]() |
RadialDimension |
The default constructor. Creates the radial
dimension entity with the center and chord points at (0, 0, 0) and
leader length of 0.0.
|
![]() |
RadialDimension(IntPtr, Boolean) |
Initializes a new instance of the RadialDimension class
|
![]() |
RadialDimension(Point3d, Point3d, Double, String, ObjectId) |
Constructor. Creates a RadialDimension object
with specified parameters.
|
Name | Description | |||||||||||||||||||||||||||||||||||||||||
---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
![]() |
AcadObject | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
AlternatePrefix |
Sets or gets the prefix for alternate
dimension measurements.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AlternateSuffix |
Sets or gets the suffix for alternate
dimension measurements.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltSuppressLeadingZeros |
Sets or gets the suppression of leading zeros
in alternate dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltSuppressTrailingZeros |
Sets or gets the suppression of trailing zeros
in alternate dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltSuppressZeroFeet |
Sets or gets the suppression of zero-foot
measurements in alternate dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltSuppressZeroInches |
Sets or gets the suppression of zero-inch
measurements in alternate dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltToleranceSuppressLeadingZeros |
Sets or gets the suppression of leading zeros
for tolerance values in alternate dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltToleranceSuppressTrailingZeros |
Sets or gets the suppression of trailing zeros
for tolerance values in alternate dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltToleranceSuppressZeroFeet |
Sets or gets the suppression of zero-foot
measurements for tolerance values in alternate dimension
values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
AltToleranceSuppressZeroInches |
Sets or gets the suppression of zero-inch
measurements for tolerance values in alternate dimension
values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Annotative | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
AutoDelete | (Inherited from DisposableWrapper.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
BlockId | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
BlockName | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Bounds | (Inherited from Drawable.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
CastShadows | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Center |
Sets or gets the three-dimensional WCS
coordinates that define the center point point of the arc or circle
being dimensioned.
|
||||||||||||||||||||||||||||||||||||||||
![]() |
CenterMarkSize |
Gets the center mark size for radial and
diameter dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
CenterMarkType |
Gets the center mark type for radial and
diameter dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ChordPoint |
Sets or gets the three-dimensional WCS
coordinates that define the intersection point of the dimension
line and the arc or circle being dimensioned.
|
||||||||||||||||||||||||||||||||||||||||
![]() |
ClassID | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
CloneMeForDragging | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
CollisionType | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Color | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
ColorIndex | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
CompoundObjectTransform | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
CurrentMeasurement |
Stores the measured value in the specified
units as a Double value. For linear dimensions — it is a length,
for angular dimensions — it is an angle.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Database | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Dimadec |
Sets or gets the number of decimal places in
the angular measured value and angular tolerance.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimalt |
Controls the display of alternate measurements
in dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltd |
Sets or gets the number of decimal places for
alternate measurements in dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltf |
Sets or gets the scale factor for alternate
linear units.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltrnd |
Sets or gets the real number to round
alternate measured values (not tolerance values).
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimalttd |
Sets or gets the number of decimal places for
alternate tolerance values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimalttz |
Sets or gets the suppression of zeros in
alternate tolerance values in dimension.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltu |
Sets or gets the format of alternate units.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaltz |
Sets or gets the suppression of zeros in
alternate measurements in dimensions.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimapost |
Sets or gets a text suffix or prefix or both
for dimension alternate measurements. Dimpost is in the form
prefix<>suffix. The '<>' in Dimpost is
replaced by the alternate measurements text.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimarcsym |
Sets or gets the type of arc symbol used
within the dimension text of the arc length dimension entity.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimasz |
Sets or gets the size of dimension lines
arrowheads.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimatfit |
Sets or gets how arrows and text are placed
when they do not fit within the extension lines of dimensions.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimaunit |
Sets or gets the format for the angular
measured value and angular tolerance value.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimazin |
Sets or gets the suppression of zeros in
angular measured values and tolerance.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk |
Sets or gets an ObjectId of the block that
form arrowheads for dimension lines.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk1 |
Sets or gets an ObjectId of the block that
form arrowheads for the first dimension line.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk1s |
Sets or gets the name of the arrowhead block
at the end of the first dimension line.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk2 |
Sets or gets an ObjectId of the block that
form arrowheads for the second dimension line.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblk2s |
Sets or gets the name of the arrowhead block
at the end of the second dimension line. The following names are
applicable:
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimblks |
Sets or gets the name of the arrowhead block
at the ends of dimension lines. The following names are applicable:
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
DimBlockId |
Sets or gets an ObjectId of the
BlockTableRecord object associated with the dimension entity.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimBlockPosition |
Sets or gets the WCS relative position of the
block that is associated with the dimension entity.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimcen |
Controls the generation of arc and circle
center marks and lines. The absolute value of Dimcen specifies the
size of the center mark, which half the length of the center mark,
which is also the length of the portion of a center line beyond the
arc or circle, as well as the length of the gap between the center
mark and line.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimclrd |
Sets or gets the color for the leader line,
arrowheads, and both dimension lines and their extensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimclre |
Sets or gets the color for the extension
lines.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimclrt |
Sets or gets the color of the dimension
text.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimdec |
Sets or gets the number of decimal places in
the primary measured value and tolerance.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimdle |
Sets or gets the length of the distance that
dimension lines are extended beyond extension lines.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimdli |
Sets or gets distance between dimension lines
for baseline dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimdsep |
Sets or gets the character to use as the
decimal separator as a char value.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimensionStyle |
Sets or gets the ObjectId for the
DimStyleTableRecord object associated with the Dimension
object.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimensionStyleName |
Gets or sets the name of a dimension style.
Setting the DimensionStyleName assigns the DimensionStyle of this
style name to the dimension if the style exists, or an exception
will be thrown if there is no style with such name.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimensionText |
Sets or gets the text string that replaces the
measured value. If the DimensionText property is an empty string,
which is the default value, the dimension entity represents the
measured value.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimexe |
Sets or gets the length of the distance that
extension lines are extended beyond dimension lines.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimexo |
Sets or gets the distance that extension lines
are offset from their origin points. Dimexo specifies a minimum
value when fixed-length extension lines are used.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimfrac |
Sets or gets the fractional format.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimfxlen |
Sets or gets the length of extension lines.
The extension line length is the distance between the beginning of
an extension line and the cross-point with a dimension line. The
extension and offset are not included in the length. If the
extension line length is a negative value, extension lines are
drawn from the outside to the cross-points with dimension lines,
towards the extension points.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
DimfxlenOn |
Sets or gets whether extension lines have a
fixed length.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimgap |
Sets or gets the distance between the
dimension text box and the dimension, extension, or leader line
according to the text position and text movement.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimjogang |
Sets and gets the jog angle of dimension lines
in jogged radius dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimjust |
Sets or gets the horizontal justification for
the dimension text box (relative to the extension lines).
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimldrblk |
Sets or gets the arrowhead block at the ends
of leader lines. A null value specifies the default arrowhead is to
be used.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimldrblks |
Sets or gets the name of the arrowhead block
at the ends of leader lines. The following names are applicable:
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlfac |
Sets or gets the linear scale factor, a
positive non-zero Double value, that influences the measured
value.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlim |
Sets or gets whether the limits are generated
as the dimension text.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimltex1 |
Sets or gets the linetype of the first
extension line.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimltex2 |
Sets or gets the linetype of the second
extension line.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimltype |
Sets or gets the linetype of the leader line,
both dimension lines, and their extensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlunit | (Inherited from Dimension.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlwd |
Sets or gets the lineweight for the leader
line, both dimension lines, and their extensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimlwe |
Sets or gets the lineweight assigned to both
the first and second extension lines.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimpost |
Sets or gets a text suffix or prefix or both
for dimension primary measurements. Dimpost is in the form
prefix<>suffix. The '<>' in Dimpost is
replaced by the primary measurements text.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimrnd |
Sets or gets the real number to round the
primary measured values (not tolerance values). For example, if the
rounding is set to 0.04, the value will be rounded to the nearest
0.04 unit. Thus, 1.912 becomes 1.92, 1.935 becomes 1.92, 1.945
becomes 1.96, and 1.972 becomes 1.96. If the rounding is set to
1.0, the value will be rounded to the nearest integer value.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimsah |
Sets and gets whether blocks set by the
Dimblk1 and Dimblk2 or a block set by the Dimblk are used as the
arrowheads for the dimension lines.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimscale |
Sets and gets the scale factor applied to all
dimension variables that regulates sizes, offsets, and distances.
The scale factor does not affect the measured lengths, angles, or
coordinates.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimsd1 |
Controls the suppression of the first
dimension line and arrowhead in dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimsd2 |
Controls the suppression of the second
dimension line and arrowhead in dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimse1 |
Controls the suppression of the first
extension line dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimse2 |
Controls the suppression of the second
extension line dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimsoxd |
Controls the suppression of dimension lines
outside the extension lines.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtad |
Sets or gets the vertical justification for
the dimension text.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtdec |
Sets or gets the number of decimal places in
tolerance values for primary units in dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtfac |
Sets or gets as a factor of Dimtxt, the size
of tolerance text in dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtfill |
Sets or gets the background fill of dimension
text.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtfillclr |
Sets or gets the background color to fill a
dimension text box.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtih |
Sets or gets the orientation of dimension text
inside the extension lines. If the Dimtih property is true, the
dimension text box is horizontally aligned. If Dimtih is false, the
dimension text box is aligned with the dimension line or leader
line.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtix |
Sets or gets the placement of a dimension text
box between the extension lines of a dimension entity. If the
Dimtix property is true, the dimension text box is required to be
placed between extension lines. If Dimtix is false, the dimension
text box is placed between extension lines only if there is
sufficient space.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtm |
Sets or gets the lower tolerance limit for
dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtmove |
Sets or gets the method of movement for a
dimension text box and dimension lines relative to one to another
while dragging.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtofl |
Controls the drawing of a forced line inside
extension lines or the definition entity when dimension lines are
placed outside of the extension lines or definition entity. This
property is true if a forced line is drawn inside (dimension lines
are connected) or false if a forced line is not drawn (dimension
lines are open-ended).
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtoh |
Controls the orientation of dimension text
outside the extension lines or definition entity. If Dimtoh
property is true, the dimension text box is horizontally aligned
when it is placed outside the extension lines or definition entity.
If Dimtoh property is false, the dimension text box is aligned
along the dimension line or leader line.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtol |
Controls the generation of tolerance text in
dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtolj |
Sets or gets the vertical justification of the
tolerance text box relative to the dimension text box.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtp |
Sets or gets the upper tolerance limit for
dimensions.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtsz |
Sets or gets the size of oblique strokes to be
drawn instead of arrowheads for linear, radial, and diameter
dimensions. Dimtsz is the distance, parallel to the dimension line,
that the tics extend beyond the extension lines. If Dimtsz = 0, the
arrowheads will be drawn. Positive values determine the size of
oblique strokes.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtvp |
Sets or gets, as a factor of Dimtxt, the
vertical distance of the middle of the dimension text with respect
to the dimension line.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtxt |
Sets or gets the dimension text size.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimtzin |
Sets or gets the suppression of zeros in
primary tolerance values in dimension.
(Inherited from Dimension.)
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimupt |
Controls the movement of user-positioned text
when dimension lines are moved. Dimupt is true if the dimension
line and the text move, and false if only the dimension line
moves.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Dimzin |
Sets or gets the suppression of zeros in
primary measured values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Drawable | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
DrawableType | (Inherited from Drawable.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
DynamicDimension |
Sets or gets whether the dimension entity is a
dynamic dimension.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Ecs | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
EdgeStyleId | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Elevation |
Sets or gets the elevation of this entity.
Elevation is the distance from the WCS origin to the plane of this
entity.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
EntityColor | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
ExtensionDictionary | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
FaceStyleId | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
ForceAnnoAllVisible | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
GeometricExtents | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Handle | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
HasFields | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
HasSaveVersionOverride | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
HorizontalRotation |
Sets or gets the rotation angle of a dimension
entity in the range from 0 to 2*PI radians.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Hyperlinks | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Id | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsAProxy | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsCancelling | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsDisposed | (Inherited from DisposableWrapper.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsErased | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsEraseStatusToggled | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsModified | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsModifiedGraphics | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsModifiedXData | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsNewObject | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsNotifyEnabled | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsNotifying | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsObjectIdsInFlux | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsPersistent | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsPlanar | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsReadEnabled | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsReallyClosing | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsTransactionResident | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsUndoing | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
IsWriteEnabled | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Layer | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
LayerId | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
LeaderLength |
Sets or gets the length from the ChordPoint to the
dogleg for this radial dimension entity.
|
||||||||||||||||||||||||||||||||||||||||
![]() |
Linetype | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
LinetypeId | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
LinetypeScale | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
LineWeight | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Material | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
MaterialId | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
MaterialMapper | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Measurement |
Stores the measured value in the specified
units as a Double value. For linear dimensions — it is a length,
for angular dimensions — it is an angle.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
MergeStyle | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Normal |
Sets or gets the three-dimensional WCS
coordinates of the normal vector.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ObjectBirthVersion | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
ObjectId | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
OwnerId | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
PaperOrientation | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
PlotStyleName | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
PlotStyleNameId | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Prefix |
Sets or gets the prefix for primary dimension
measurements.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ReceiveShadows | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
Suffix |
Sets or gets the suffix for primary dimension
measurements.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressAngularLeadingZeros |
Sets or gets the suppression of leading zeros
in angular dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressAngularTrailingZeros |
Sets or gets the suppression of trailing zeros
in angular dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressLeadingZeros |
Sets or gets the suppression of leading zeros
in primary dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressTrailingZeros |
Sets or gets the suppression of trailing zeros
in primary dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressZeroFeet |
Sets or gets the suppression of zero-foot
measurements in primary dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
SuppressZeroInches |
Sets or gets the suppression of zero-inch
measurements in primary dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextAttachment |
Sets or gets the dimension text justification
mode within the text box.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextLineSpacingFactor |
Sets or gets the relative distance between
adjoining base lines of text strings. The line spacing factor can
have a value in the range of 0.25 to 4.0.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextLineSpacingStyle |
Sets or gets the dimension text line spacing
style for this Dimension object.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextPosition |
Sets or gets the three-dimensional coordinates
of the text position as a Point3d value.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextRotation |
Sets or gets the rotation angle of a dimension
text box in radians.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
TextStyleId |
Sets or gets the text style of the dimension
text.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ToleranceSuppressLeadingZeros |
Sets or gets the suppression of leading zeros
for tolerance values in primary dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ToleranceSuppressTrailingZeros |
Sets or gets the suppression of trailing zeros
for tolerance values in primary dimension values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ToleranceSuppressZeroFeet |
Sets or gets the suppression of zero-foot
measurements for tolerance values in primary dimension
values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
ToleranceSuppressZeroInches |
Sets or gets the suppression of zero-inch
measurements for tolerance values in primary dimension
values.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Transparency | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
UndoFiler | (Inherited from DBObject.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
UsingDefaultTextPosition |
Defines whether the default position is used
for dimension text or not. If true then the default text position
is used. To set a new text position, the false value must be
set.
(Inherited from Dimension.) |
||||||||||||||||||||||||||||||||||||||||
![]() |
Visible | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
VisualStyleId | (Inherited from Entity.) | ||||||||||||||||||||||||||||||||||||||||
![]() |
XData | (Inherited from DBObject.) |
Name | Description | |
---|---|---|
![]() |
Cancelled | (Inherited from DBObject.) |
![]() |
Copied | (Inherited from DBObject.) |
![]() |
Erased | (Inherited from DBObject.) |
![]() |
Goodbye | (Inherited from DBObject.) |
![]() |
Modified | (Inherited from DBObject.) |
![]() |
ModifiedXData | (Inherited from DBObject.) |
![]() |
ModifyUndone | (Inherited from DBObject.) |
![]() |
ObjectClosed | (Inherited from DBObject.) |
![]() |
OpenedForModify | (Inherited from DBObject.) |
![]() |
Reappended | (Inherited from DBObject.) |
![]() |
SubObjectModified | (Inherited from DBObject.) |
![]() |
Unappended | (Inherited from DBObject.) |
© Bricsys NV. All rights reserved. |