Curve3dIsLinear Method (Line3d)
|
Checks whether this curve is linear.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public bool IsLinear(
out Line3d line
)
Public Function IsLinear (
<OutAttribute> ByRef line As Line3d
) As Boolean
public:
bool IsLinear(
[OutAttribute] Line3d^% line
)
member IsLinear :
line : Line3d byref -> bool
Parameters
- line
- Type: Teigha.GeometryLine3d
[out] Receives the line coincident with this curve.
Return Value
Type:
Boolean
true if this curve is linear,
false otherwise.
Remarks
The line parameter cannot have a relevant data if the
method returns false.
See Also