CurveBoundary Constructor (Int32, Curve3d, Curve2d, Boolean, Boolean)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CurveBoundary(
int numberOfCurves,
Curve3d[] curve3d,
Curve2d[] curve2d,
bool orientation3d,
bool orientation2d
)
Public Sub New (
numberOfCurves As Integer,
curve3d As Curve3d(),
curve2d As Curve2d(),
orientation3d As Boolean,
orientation2d As Boolean
)
public:
CurveBoundary(
int numberOfCurves,
array<Curve3d^>^ curve3d,
array<Curve2d^>^ curve2d,
bool orientation3d,
bool orientation2d
)
new :
numberOfCurves : int *
curve3d : Curve3d[] *
curve2d : Curve2d[] *
orientation3d : bool *
orientation2d : bool -> CurveBoundary
Parameters
- numberOfCurves
- Type: SystemInt32
- curve3d
- Type: Teigha.GeometryCurve3d
- curve2d
- Type: Teigha.GeometryCurve2d
- orientation3d
- Type: SystemBoolean
- orientation2d
- Type: SystemBoolean
See Also