TransactionManagerGetObject Method (ObjectId, OpenMode, Boolean)

Calls the OpenObject() method of the underlaying C++ object for the passed id within the specified open mode.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public virtual DBObject GetObject(
        ObjectId id,
        OpenMode mode,
        bool openErased
)

Parameters

id
Type: Teigha.DatabaseServicesObjectId
[in] Identifier of the object to obtain access to.
mode
Type: Teigha.DatabaseServicesOpenMode
[in] Mode to obtain in.
openErased
Type: SystemBoolean
[in] Flag that specifies whether to obtain an object if it was erased.

Return Value

Type: DBObject
A handle to the retrieved object.
Remarks
It is recommended to check whether the retrieved object is valid after method execution.
See Also

©  Bricsys NV. All rights reserved.