DBObject Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public abstract class DBObject : Drawable

The DBObject type exposes the following members.

Constructors
  Name Description
Protected method DBObject
Initializes a new instance of the DBObject class
Top
Properties
Methods
  Name Description
Public method AddContext
Public method AddPersistentReactor
Public method ApplyPartialUndo
Protected method AssertNotifyEnabled
Protected method AssertReadEnabled
Protected method AssertWriteEnabled
Public method Audit
Public method Cancel Obsolete.
Public method Close Obsolete.
Public method CloseAndPage Obsolete.
Public method CreateExtensionDictionary
Public method DecomposeForSave
Public method DeepClone
Protected method DeleteUnmanagedObject (Overrides RXObjectDeleteUnmanagedObject.)
Public method DisableUndoRecording
Protected method Dispose(Boolean)
Releases the unmanaged resources used by the DBObject and optionally releases the managed resources
(Overrides DisposableWrapperDispose(Boolean).)
Public method DowngradeOpen
Public method DowngradeToNotify
Public method DwgIn
Protected method DwgInFields
Public method DwgOut
Protected method DwgOutFields
Public method DxfIn
Protected method DxfInFields
Public method DxfOut
Protected method DxfOutFields
Public method Erase
Public method Erase(Boolean)
Public methodStatic member FromAcadObject
Public method GetEventExtender
Public method GetField
Public method GetField(String)
Public method GetObjectSaveVersion(DwgFiler)
Public method GetObjectSaveVersion(DxfFiler)
Public method GetPersistentReactorIds
Public method GetReactors Obsolete.
Public method GetTransientReactors
Public method GetXDataForApplication
Public method HandOverTo
Public method HasContext
Public method HasPersistentReactor
Public methodStatic member IsCustomObject
Public method ReleaseExtensionDictionary
Public method RemoveContext
Public method RemoveField
Public method RemoveField(String)
Public method RemoveField(ObjectId)
Public method RemovePersistentReactor
Public method ResetScaleDependentProperties
Public method SetField(Field)
Public method SetField(String, Field)
Public method SetFromStyle
Public method SetObjectIdsInFlux
Public method SetPaperOrientation
Protected method SubSetAttributes (Overrides DrawableSubSetAttributes(DrawableTraits).)
Protected method SubViewportDraw (Overrides DrawableSubViewportDraw(ViewportDraw).)
Protected method SubViewportDrawLogicalFlags (Overrides DrawableSubViewportDrawLogicalFlags(ViewportDraw).)
Protected method SubWorldDraw (Overrides DrawableSubWorldDraw(WorldDraw).)
Public method SupportsCollection
Public method SwapIdWith
Public method SwapReferences
Public method UpgradeFromNotify
Public method UpgradeOpen
Public method WblockClone
Public method XDataTransformBy
Top
Events
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Teigha.DatabaseServicesAssocAction
            Teigha.DatabaseServicesAssocDependency
            Teigha.DatabaseServicesAssocManager
            Teigha.DatabaseServicesBackground
            Teigha.DatabaseServicesDataLink
            Teigha.DatabaseServicesDataTable
            Teigha.DatabaseServicesDBDictionary
            Teigha.DatabaseServicesDBVisualStyle
            Teigha.DatabaseServicesDimAssoc
            Teigha.DatabaseServicesDrawOrderTable
            Teigha.DatabaseServicesEntity
            Teigha.DatabaseServicesField
            Teigha.DatabaseServices.FiltersFilter
            Teigha.DatabaseServices.FiltersIndex
            Teigha.DatabaseServicesGeoLocationData
            Teigha.DatabaseServicesGroup
            Teigha.DatabaseServicesLinkedData
            Teigha.DatabaseServicesMaterial
            Teigha.DatabaseServicesMLeaderStyle
            Teigha.DatabaseServicesMlineStyle
            Teigha.DatabaseServicesPlaceHolder
            Teigha.DatabaseServicesPlotSettings
            Teigha.DatabaseServicesProxyObject
            Teigha.DatabaseServicesRasterImageDef
            Teigha.DatabaseServicesRasterVariables
            Teigha.DatabaseServicesRenderEnvironment
            Teigha.DatabaseServicesRenderGlobal
            Teigha.DatabaseServicesRenderSettings
            Teigha.DatabaseServicesSectionManager
            Teigha.DatabaseServicesSectionSettings
            Teigha.DatabaseServicesSun
            Teigha.DatabaseServicesSymbolTable
            Teigha.DatabaseServicesSymbolTableRecord
            Teigha.DatabaseServicesTableStyle
            Teigha.DatabaseServicesUnderlayDefinition
            Teigha.DatabaseServicesXrecord

©  Bricsys NV. All rights reserved.