AssocManagerEvaluateTopLevelNetwork Method
|
Evaluates the top-level associative network
(represented by AssocNetwork) of the specified database, using the
global evaluation callback.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public static bool EvaluateTopLevelNetwork(
Database database,
Object callback,
int callbackOrder
)
Public Shared Function EvaluateTopLevelNetwork (
database As Database,
callback As Object,
callbackOrder As Integer
) As Boolean
public:
static bool EvaluateTopLevelNetwork(
Database^ database,
Object^ callback,
int callbackOrder
)
static member EvaluateTopLevelNetwork :
database : Database *
callback : Object *
callbackOrder : int -> bool
Parameters
- database
- Type: Teigha.DatabaseServicesDatabase
[in] Database whose top-level network should be evaluated.
- callback
- Type: SystemObject
[in] Custom-defined callback to be referenced by the
AssocEvaluationMultiCallback object.
- callbackOrder
- Type: SystemInt32
[in] Order of calling the custom-defined callbacks. Lower order
specifies that this callback is called before callbacks with higher
order.
Return Value
Type:
Boolean
See Also