AssocManager Class |
This .NET class wraps the OdDbAssocManager class.
This class globally manages the associative framework. There is only one instance of the manager per database.
The AssocManager type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AssocManager |
Default constructor for the AssocManager
class. Creates an object that wraps a corresponding C++
OdDbAssocManager object.
|
Name | Description | |
---|---|---|
![]() |
AcadObject | (Inherited from DBObject.) |
![]() |
Annotative | (Inherited from DBObject.) |
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Bounds | (Inherited from Drawable.) |
![]() |
ClassID | (Inherited from DBObject.) |
![]() |
Database | (Inherited from DBObject.) |
![]() |
Drawable | (Inherited from DBObject.) |
![]() |
DrawableType | (Inherited from Drawable.) |
![]() |
ExtensionDictionary | (Inherited from DBObject.) |
![]() |
Handle | (Inherited from DBObject.) |
![]() |
HasFields | (Inherited from DBObject.) |
![]() |
HasSaveVersionOverride | (Inherited from DBObject.) |
![]() |
Id | (Inherited from DBObject.) |
![]() |
IsAProxy | (Inherited from DBObject.) |
![]() |
IsCancelling | (Inherited from DBObject.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsErased | (Inherited from DBObject.) |
![]() |
IsEraseStatusToggled | (Inherited from DBObject.) |
![]() |
IsModified | (Inherited from DBObject.) |
![]() |
IsModifiedGraphics | (Inherited from DBObject.) |
![]() |
IsModifiedXData | (Inherited from DBObject.) |
![]() |
IsNewObject | (Inherited from DBObject.) |
![]() |
IsNotifyEnabled | (Inherited from DBObject.) |
![]() |
IsNotifying | (Inherited from DBObject.) |
![]() |
IsObjectIdsInFlux | (Inherited from DBObject.) |
![]() |
IsPersistent | (Inherited from DBObject.) |
![]() |
IsReadEnabled | (Inherited from DBObject.) |
![]() |
IsReallyClosing | (Inherited from DBObject.) |
![]() |
IsTransactionResident | (Inherited from DBObject.) |
![]() |
IsUndoing | (Inherited from DBObject.) |
![]() |
IsWriteEnabled | (Inherited from DBObject.) |
![]() |
MergeStyle | (Inherited from DBObject.) |
![]() |
ObjectBirthVersion | (Inherited from DBObject.) |
![]() |
ObjectId | (Inherited from DBObject.) |
![]() |
OwnerId | (Inherited from DBObject.) |
![]() |
PaperOrientation | (Inherited from DBObject.) |
![]() |
UndoFiler | (Inherited from DBObject.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
XData | (Inherited from DBObject.) |
Name | Description | |
---|---|---|
![]() |
AddContext | (Inherited from DBObject.) |
![]() ![]() |
AddGlobalEvaluationCallback |
Adds the specified callback object to the
global AssocEvaluationMultiCallback object.
|
![]() |
AddPersistentReactor | (Inherited from DBObject.) |
![]() |
ApplyPartialUndo | (Inherited from DBObject.) |
![]() |
AssertNotifyEnabled | (Inherited from DBObject.) |
![]() |
AssertReadEnabled | (Inherited from DBObject.) |
![]() |
AssertWriteEnabled | (Inherited from DBObject.) |
![]() |
Audit | (Inherited from DBObject.) |
![]() ![]() |
AuditAssociativeData |
Audits the associative data in the database
and attempts to resolve errors if they exist.
|
![]() |
Cancel | Obsolete. (Inherited from DBObject.) |
![]() |
Clone | (Inherited from RXObject.) |
![]() |
Close | Obsolete. (Inherited from DBObject.) |
![]() |
CloseAndPage | Obsolete. (Inherited from DBObject.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateExtensionDictionary | (Inherited from DBObject.) |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DecomposeForSave | (Inherited from DBObject.) |
![]() |
DeepClone | (Inherited from DBObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from DBObject.) |
![]() |
DisableUndoRecording | (Inherited from DBObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DBObject.) |
![]() |
DowngradeOpen | (Inherited from DBObject.) |
![]() |
DowngradeToNotify | (Inherited from DBObject.) |
![]() |
DwgIn | (Inherited from DBObject.) |
![]() |
DwgInFields | (Inherited from DBObject.) |
![]() |
DwgOut | (Inherited from DBObject.) |
![]() |
DwgOutFields | (Inherited from DBObject.) |
![]() |
DxfIn | (Inherited from DBObject.) |
![]() |
DxfInFields | (Inherited from DBObject.) |
![]() |
DxfOut | (Inherited from DBObject.) |
![]() |
DxfOutFields | (Inherited from DBObject.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Erase | (Inherited from DBObject.) |
![]() |
Erase(Boolean) | (Inherited from DBObject.) |
![]() ![]() |
EvaluateTopLevelNetwork |
Evaluates the top-level associative network
(represented by AssocNetwork) of the specified database, using the
global evaluation callback.
|
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetEventExtender | (Inherited from DBObject.) |
![]() |
GetField | (Inherited from DBObject.) |
![]() |
GetField(String) | (Inherited from DBObject.) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.) |
![]() |
GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.) |
![]() |
GetPersistentReactorIds | (Inherited from DBObject.) |
![]() |
GetReactors | Obsolete. (Inherited from DBObject.) |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetTransientReactors | (Inherited from DBObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
GetXDataForApplication | (Inherited from DBObject.) |
![]() |
HandOverTo | (Inherited from DBObject.) |
![]() ![]() |
HasAssocNetwork |
Checks whether the specified database has the
global associative network (represented by AssocNetwork). Currently
not implemented.
|
![]() |
HasContext | (Inherited from DBObject.) |
![]() |
HasPersistentReactor | (Inherited from DBObject.) |
![]() ![]() |
Initialize |
The internal method that initializes the
Associative Framework. Currently not implemented.
|
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
ReleaseExtensionDictionary | (Inherited from DBObject.) |
![]() |
RemoveContext | (Inherited from DBObject.) |
![]() |
RemoveField | (Inherited from DBObject.) |
![]() |
RemoveField(String) | (Inherited from DBObject.) |
![]() |
RemoveField(ObjectId) | (Inherited from DBObject.) |
![]() ![]() |
RemoveGlobalEvaluationCallback |
Removes the specified evaluation callback from
the global AssocEvaluationMultiCallback. Currently not
implemented.
|
![]() |
RemovePersistentReactor | (Inherited from DBObject.) |
![]() |
ResetScaleDependentProperties | (Inherited from DBObject.) |
![]() |
SetAttributes | (Inherited from Drawable.) |
![]() |
SetField(Field) | (Inherited from DBObject.) |
![]() |
SetField(String, Field) | (Inherited from DBObject.) |
![]() |
SetFromStyle | (Inherited from DBObject.) |
![]() |
SetObjectIdsInFlux | (Inherited from DBObject.) |
![]() |
SetPaperOrientation | (Inherited from DBObject.) |
![]() |
SubSetAttributes | (Inherited from DBObject.) |
![]() |
SubViewportDraw | (Inherited from DBObject.) |
![]() |
SubViewportDrawLogicalFlags | (Inherited from DBObject.) |
![]() |
SubWorldDraw | (Inherited from DBObject.) |
![]() |
SupportsCollection | (Inherited from DBObject.) |
![]() |
SwapIdWith | (Inherited from DBObject.) |
![]() |
SwapReferences | (Inherited from DBObject.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
UpgradeFromNotify | (Inherited from DBObject.) |
![]() |
UpgradeOpen | (Inherited from DBObject.) |
![]() |
ViewportDraw | (Inherited from Drawable.) |
![]() |
ViewportDrawLogicalFlags | (Inherited from Drawable.) |
![]() |
WblockClone | (Inherited from DBObject.) |
![]() |
WorldDraw | (Inherited from Drawable.) |
![]() |
X | (Inherited from RXObject.) |
![]() |
XDataTransformBy | (Inherited from DBObject.) |
Name | Description | |
---|---|---|
![]() |
Cancelled | (Inherited from DBObject.) |
![]() |
Copied | (Inherited from DBObject.) |
![]() |
Erased | (Inherited from DBObject.) |
![]() |
Goodbye | (Inherited from DBObject.) |
![]() |
Modified | (Inherited from DBObject.) |
![]() |
ModifiedXData | (Inherited from DBObject.) |
![]() |
ModifyUndone | (Inherited from DBObject.) |
![]() |
ObjectClosed | (Inherited from DBObject.) |
![]() |
OpenedForModify | (Inherited from DBObject.) |
![]() |
Reappended | (Inherited from DBObject.) |
![]() |
SubObjectModified | (Inherited from DBObject.) |
![]() |
Unappended | (Inherited from DBObject.) |
© Bricsys NV. All rights reserved. |