EdgeRef Constructor (CompoundObjectId, SubentityId,
SubentityId)
|
Constructor for the EdgeRef class. Creates an
edge reference based on the specified full sub-entity path.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public EdgeRef(
CompoundObjectId compoundObjectId,
SubentityId edgeSubentId,
SubentityId faceSubentId
)
Public Sub New (
compoundObjectId As CompoundObjectId,
edgeSubentId As SubentityId,
faceSubentId As SubentityId
)
public:
EdgeRef(
CompoundObjectId^ compoundObjectId,
SubentityId edgeSubentId,
SubentityId faceSubentId
)
new :
compoundObjectId : CompoundObjectId *
edgeSubentId : SubentityId *
faceSubentId : SubentityId -> EdgeRef
Parameters
- compoundObjectId
- Type: Teigha.DatabaseServicesCompoundObjectId
[in] Identifier of the compound object that is the base of this
edge reference.
- edgeSubentId
- Type: Teigha.DatabaseServicesSubentityId
[in] Edge sub-entity.
- faceSubentId
- Type: Teigha.DatabaseServicesSubentityId
[in] Face sub-entity.
See Also