CompoundObjectId Class |
The CompoundObjectId type exposes the following members.
Name | Description | |
---|---|---|
![]() |
CompoundObjectId |
Initializes a new instance of the CompoundObjectId class
|
![]() |
CompoundObjectId(CompoundObjectId) |
Initializes a new instance of the CompoundObjectId class
|
![]() |
CompoundObjectId(ObjectId) |
Initializes a new instance of the CompoundObjectId class
|
![]() |
CompoundObjectId(ObjectId, Database) |
Initializes a new instance of the CompoundObjectId class
|
![]() |
CompoundObjectId(ObjectId, ObjectIdCollection, Database) |
Initializes a new instance of the CompoundObjectId class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
FullPath | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsEmpty | |
![]() |
IsExternal | |
![]() |
IsSimpleObjectId | |
![]() |
LeafId | |
![]() |
Path | |
![]() |
TopId | |
![]() |
Transform | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
DwgInFields | |
![]() |
DwgOutFields | |
![]() |
DxfInFields | |
![]() |
DxfOutFields | |
![]() |
Equals | (Overrides DisposableWrapperEquals(Object).) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsValid | |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() ![]() |
NullId | |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
Remap | |
![]() |
Set(CompoundObjectId, Database) | |
![]() |
Set(ObjectId, Database) | |
![]() |
Set(ObjectId, ObjectIdCollection, Database) | |
![]() |
SetEmpty | |
![]() |
SetFullPath | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
X | (Inherited from RXObject.) |
Name | Description | |
---|---|---|
![]() |
Assign(CompoundObjectId) | |
![]() |
Assign(ObjectId) | |
![]() |
Equality | |
![]() |
Inequality |
© Bricsys NV. All rights reserved. |