NurbCurve2d Constructor (Int32, KnotCollection,
Point2dCollection, Boolean)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public NurbCurve2d(
int degree,
KnotCollection knots,
Point2dCollection controlPoints,
bool periodic
)
Public Sub New (
degree As Integer,
knots As KnotCollection,
controlPoints As Point2dCollection,
periodic As Boolean
)
public:
NurbCurve2d(
int degree,
KnotCollection^ knots,
Point2dCollection^ controlPoints,
bool periodic
)
new :
degree : int *
knots : KnotCollection *
controlPoints : Point2dCollection *
periodic : bool -> NurbCurve2d
Parameters
- degree
- Type: SystemInt32
- knots
- Type: Teigha.GeometryKnotCollection
- controlPoints
- Type: Teigha.GeometryPoint2dCollection
- periodic
- Type: SystemBoolean
See Also