AssocActionRemoveActionsControllingObject Method (ObjectId, Int32)

Detaches the write dependencies of the specified object. The dependencies are detached in reverse order, starting from the object's last write dependency and finishing with the first. Currently not implemented.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public static void RemoveActionsControllingObject(
        ObjectId objID,
        int readOnlyDependencyHandling
)

Parameters

objID
Type: Teigha.DatabaseServicesObjectId
[in] Database object for which to remove write dependencies.
readOnlyDependencyHandling
Type: SystemInt32
[in] Defines how to process read-only dependencies.
Remarks
The readOnlyDependencyHandling possible values:
Value Description
0 Keep all read-only dependencies, or redirect them to another object, if specified. Dependencies on the intermediate object state then depend on the last object state of the object, which can sometimes provide incorrect results.
1 Keep all read-only dependencies, or redirect them to another object, if specified and they depend on the last object state.
2 Drop all dependencies on the object.
See Also

©  Bricsys NV. All rights reserved.