AssocAction Class

This .NET class wraps the OdDbAssocAction class.

Every object that needs to show associative behavior, i.e. when objects that rely on change are automatically evaluated by the associative mechanism, must be derived from an AssocActionBody class and owned by a parent AssocAction entity. The action body is owned by its parent action, for example when the parent action is deleted, it also erases the action body that is owned.

The AssocAction class does not have virtual methods that can be overridden, therefore it should be done internally when there is no chance that objects of the derived action classes can become proxies.

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class AssocAction : DBObject

The AssocAction type exposes the following members.

Constructors
  Name Description
Public method AssocAction
Default constructor for the AssocAction class. Wraps the result of the corresponding C++ createObject() method call.
Top
Properties
  Name Description
Public property ActionBody
Public property IsActionBodyAProxy
Public property IsActionEvaluationInProgress
Public property OwningNetwork
Public property Status
Top
Methods
  Name Description
Public method AddDependency
Adds the specified dependency to this action.
Public method AddMoreObjectsToDeepClone
Adds more objects to be deep cloned. Call just before the end of the main deep-cloning loop, when the objects are already cloned but their identifiers aren't translated yet.
Public method AreDependenciesEqual
Checks whether the specified dependencies are equal.
Public method AreDependenciesOnTheSameThing
Checks whether the specified dependencies are dependent on the same "thing."
Public method DependentObjectCloned
Notifies the owning action that an object, that the action has a dependency on, is cloned. All cloning types are accepted (shallow, deep or wblock).
Public method DragStatus
Notifies the action when there is a drag operation in progress for objects that the action depends on.
Public method EvaluateDependencies
Should be called from the client code via the evaluateOverride() method, usually after analyzing dependencies, detecting changes, determining which are on erased objects, etc.
Public method EvaluateDependency
Allows the owner action to do the work instead of the dependency itself.
Public method EvaluationPriority
Determines the evaluation priority of this action.
Public methodStatic member GetActionBody
Retrieves the object identifier of the action body. Currently not implemented.
Public methodStatic member GetActionsDependentOnObject(DBObject, Boolean, Boolean)
Retrieves the actions depending on the specified database object.
Public methodStatic member GetActionsDependentOnObject(DBObject, Boolean, Boolean, ObjectIdCollection)
Retrieves the actions depending on the specified database object.
Public method GetDependencies
Retrieves dependencies of this action.
Public method GetDependentObjects
Retrieves objects that this action depends on or modifies.
Public method HasDependencyCachedValue
Checks whether the specified dependency has a cached value.
Public method IsEqualTo
Checks whether the specified action is equal to this action. Does nothing in the current implementation.
Public method IsExternalDependency
Checks whether the specified dependency, which is owned by this action, depends on the database object that is not this action and is not owned by this action. If the dependency doesn't depend on any object, it's also assumed external.
Public method IsOwnedDependency
Checks whether the specified dependency is owned by this action.
Public method IsRelevantDependencyChange
Allows the owning action, instead of the dependency, to determine whether the object change is relevant to the specified dependency.
Public method ObjectThatOwnsNetworkInstance
Searches for the object that owns the network instance, i.e. finds the database object for which the GetInstanceFromObject() method returns the AssocNetwork.
Public method OwnedDependencyStatusChanged
Informs the dependency-owning action that the dependency status is modified. Usually called from the AssocDependency.SetStatus() method.
Public method PostProcessAfterDeepClone
Informs the source actions that they are cloned, so that they can update the clones or perform other tasks if needed. Usually called from the reactor notification method.
Public method PostProcessAfterDeepCloneCancel
Cancels the post processing of the cloned action after deep cloning.
Public methodStatic member RemoveActionsControllingObject(ObjectId)
Detaches the write dependencies of the specified object. The dependencies are detached in reverse order, starting from the object's last write dependency and finishing with the first. Currently not implemented.
Public methodStatic member RemoveActionsControllingObject(ObjectId, Int32)
Detaches the write dependencies of the specified object. The dependencies are detached in reverse order, starting from the object's last write dependency and finishing with the first. Currently not implemented.
Public methodStatic member RemoveActionsControllingObject(ObjectId, Int32, ObjectId)
Detaches the write dependencies of the specified object. The dependencies are detached in reverse order, starting from the object's last write dependency and finishing with the first. Currently not implemented.
Public method RemoveAllDependencies
Removes all dependencies associated with this action.
Public method RemoveDependency
Removes the specified dependency associated with this action.
Public method SetOwningNetwork
Sets the owning network for this action. Should not be called directly, instead it is called from the AssocNetwork.AddAction() and AssocNetwork.RemoveAction() methods.
Public method SetStatus
Sets the status for this action.
Public method TransformActionBy
Notifes the action that the owner of the action is transformed.
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.