TorusSet Method (Double, Double, Point3d, Vector3d, Vector3d,
Double, Double, Double, Double)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
double majorRadius,
double minorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d refAxis,
double startAngleU,
double endAngleU,
double startAngleV,
double endAngleV
)
Public Sub Set (
majorRadius As Double,
minorRadius As Double,
origin As Point3d,
axisOfSymmetry As Vector3d,
refAxis As Vector3d,
startAngleU As Double,
endAngleU As Double,
startAngleV As Double,
endAngleV As Double
)
public:
void Set(
double majorRadius,
double minorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d refAxis,
double startAngleU,
double endAngleU,
double startAngleV,
double endAngleV
)
member Set :
majorRadius : float *
minorRadius : float *
origin : Point3d *
axisOfSymmetry : Vector3d *
refAxis : Vector3d *
startAngleU : float *
endAngleU : float *
startAngleV : float *
endAngleV : float -> unit
Parameters
- majorRadius
- Type: SystemDouble
- minorRadius
- Type: SystemDouble
- origin
- Type: Teigha.GeometryPoint3d
- axisOfSymmetry
- Type: Teigha.GeometryVector3d
- refAxis
- Type: Teigha.GeometryVector3d
- startAngleU
- Type: SystemDouble
- endAngleU
- Type: SystemDouble
- startAngleV
- Type: SystemDouble
- endAngleV
- Type: SystemDouble
See Also