Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public static Matrix3d Rotation(
double angle,
Vector3d axis,
Point3d center
)
Public Shared Function Rotation (
angle As Double,
axis As Vector3d,
center As Point3d
) As Matrix3d
public:
static Matrix3d Rotation(
double angle,
Vector3d axis,
Point3d center
)
static member Rotation :
angle : float *
axis : Vector3d *
center : Point3d -> Matrix3d
Parameters
- angle
- Type: SystemDouble
- axis
- Type: Teigha.GeometryVector3d
- center
- Type: Teigha.GeometryPoint3d
Return Value
Type:
Matrix3d
See Also