dos_command


(dos_command  command  [mode])

Runs the specified OS command (like when starting from a DOS box or terminal box.

command :is a string specifying the OS command including all parameters

mode :is an integer to control the behaviour of the OS shell box :
0        show the shell window in normal (last-used) mode
1        show the shell window in normal (last-used) mode, but is not activated
2        show the shell window in minimised, but inactive state
3        show the shell window in minimised, and active state
4        show the shell window in maximised state

Returns the string executed in OS command shell, or NIL in case of an error.

Examples :

(dos_command "notepad.exe" 1)     runs Notepad.exe with normal shell box
(dos_command "notepad.exe" 3)     runs Notepad.exe with minimised shell box

(dos_command "services.msc" 1)    runs control panel with normal shell box
(dos_command "services.msc" 3)    runs control panel with minimised shell box


©  Bricsys NV. All rights reserved.