vl-catch-all-error-message


(vl-catch-all-error-message errObject)

This function returns the error message associated with errObject (Lisp error object, as returned from (vl-catch-all-apply) function call).

Arguments

errObject  (Lisp error object) as returned from (vl-catch-all-apply)

Return

string; the associated error message

Example

(setq res (vl-catch-all-apply 'strcat '("aaa" 123)))  returns #<catch-all-apply-error>
(vl-catch-all-error-message res)  returns "bad argument type <123> ; expected <STRING> at [strcat]"

Remarks

returns an error, if errObject is not a Lisp error object !
upfront verification by (vl-catch-all-error-p) is mandatory !



©  Bricsys NV. All rights reserved.