vl-catch-all-error-p


(vl-catch-all-error-p lspObject)

This function returns whether lspObject is a 'Lisp error object' as potentially returned from (vl-catch-all-apply) function call.

Arguments

lspObject  (any Lisp value) the Lisp value to be verified

Return

returns T or NIL

Example

(setq res (vl-catch-all-apply 'strcat '("aaa" 123)))  returns #<catch-all-apply-error>
(vl-catch-all-error-p res)  returns T

Remarks

see (vl-catch-all-apply) and (vl-catch-all-error-message) functions



©  Bricsys NV. All rights reserved.