vl-vplayer-set-lineweight
(vl-vplayer-set-lineweight layer
viewport lineweight)
This function sets the viewport-specific
lineweight override for the layer.
(layer
can specify one or more layers)
Arguments
|
layer specifies one or more layer(s) to apply the
viewport-specific lineweight
can be :
1. name (string) the name of 1
layer
2. ename (ename) the entity name
of the layer
3. enameList (list of name | ename)
list of 1 or more layer entity string names and/or
enames
viewport specifies one or more viewport
can be
1. ename (ename) the viewport's entity
name
2. cvport (integer) the viewport's
CVPORT viewport number
3. (list ename cvport ...) list ename(s)
and/or cvport(s)
lineweight (integer) the lineweight value to be assigned;
if NIL, any lineweight override is removed
can be (symbolic name = integer
value)
acLnWt000 = 0
acLnWt005 = 5
acLnWt009 = 9
acLnWt013 = 13
acLnWt015 = 15
acLnWt018 = 18
acLnWt020 = 20
acLnWt025 = 25
acLnWt030 = 30
acLnWt035 = 35
acLnWt040 = 40
acLnWt050 = 50
acLnWt053 = 53
acLnWt060 = 60
acLnWt070 = 70
acLnWt080 = 80
acLnWt090 = 90
acLnWt100 = 100
acLnWt106 = 106
acLnWt120 = 120
acLnWt140 = 140
acLnWt158 = 158
acLnWt200 = 200
acLnWt211 = 211
acLnWtByLayer = -1
acLnWtByBlock = -2
acLnWtByLwDefault = -3
|
|
Return
|
T if the lineweight value is
successfully applied, NIL otherwise
|
Example
|
|
Remarks
|
this is a BricsCAD-specific
function !
|