vle-cadrassoc


(vle-cadrassoc  key  lst)

searches 'lst' list for a dotted-pair with key 'key' and returns the (cadr) of its value;

Arguments

key  key value for the dotted pair value to search for

lst  list of dotted pairs

Return

the (cadr) of the value of a dotted pair (key . value), if a dotted pair with key key, if present in the list lst;
NIL if not present

Example

(vle-cadrassoc 11 '((1 (0 0 0)) (2 (1 1 1)) (11 (1 2 3))))
returns (1 2 3)

Alias

vle-get-cadrassoc

Remarks

replacement for (cadr (assoc key lst))



©  Bricsys NV. All rights reserved.